ldcf.net
相关文档
当前位置:首页 >> sCrApy python3 >>

sCrApy python3

根据scrapy的文档,现在开发人员正在向python3迁移,也就是说目前只能完全支持python2。因此,解决方案有三个: 用python2 等待scrapy迁移完 不用python3不支持的特性

找了好几个网站,终于找到以下内容了. Python 3.3+的支持已经在计划中了。 现在,Scrapy支持Python 2.7。 所以如果要用的话可以在python2里面用.

目前 Scrapy 只是在 Py 2.7 上面较为稳定 这是一个框架,包含下图所示内容: 只需要在 spiders 路径下,编辑 py 文件即可运行 总体来讲还是很好的一个框架 如果是使用 pycharm 的话,在 py2 与 py3 之间切换很方便

支持!哪个说的不支持?! 我的环境win7 + python3,可以安装scrapy。 不过直接:pip install scrapy 是不会安装成功的。 我是先安装了numpy之后再安装才成功!!

我觉得是twisted不支持python3才导致的scrapy还不支持python3. 比较scrapy是基于twisted库开发的。呵呵~ One popular module that don't yet support Python 3 is Twisted (for networking and other applications). python官网上说的,所以如果...

1、scrapy的开发者已经把Python3的支持放在很重要的位置上了,谷歌编程之夏上有个项目就是移植scrapy到Python3.x上。 2、但是要支持Python3还是有很多难关去攻克,主要来自scrapy依赖的一些库twisted和mitmproxy等。

1安装python:版本3.6(对照自己的操作系统下载相应版本) 2最新版本3.6自带pip,在安装路径里可以找到,一般在C:(自己的安装路径)\python\scriprts文件中。 3打开cmd,(如果打开的pythonIDE话,是不可以用的,提示语法错误)输入 pip,回车...

目前 Scrapy 只是在 Py 2.7 上面较为稳定 这是一个框架,包含下图所示内容: 只需要在 spiders 路径下,编辑 py 文件即可运行 总体来讲还是很好的一个框架 如果是使用 pycharm 的话,在 py2 与 py3 之间切换很方便

支持。先在网络上找到你对python版本的twisted模块,然后pip install scrapy的方式安装就可以安装成功。我也是用py3,scrapy用很久了。

支持,我用py3.5,scrapy用了挺久了。

网站首页 | 网站地图
All rights reserved Powered by www.ldcf.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com